GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Infotainment Hardware and Software Updates

Braxton

New member
True or False? factoid from today's (27/07) Steve Wright In The Afternoon show (BBC R2) some car's software can contain up to 100 million lines of code! Maybe we're being a bit hard on VW :giggle:
I'm a software engineer. Code bases are so complex that it's difficult to keep how it works in your head.

However when they says it's a million lines they are counting third party code that you use in projects. I'm sure it's less than 100k lines and even then it's conditions, reading information , writing information. It's still complex and difficult to get right
 

LMWT

Go Kart Newbie
I'm a software engineer. Code bases are so complex that it's difficult to keep how it works in your head.

However when they says it's a million lines they are counting third party code that you use in projects. I'm sure it's less than 100k lines and even then it's conditions, reading information , writing information. It's still complex and difficult to get right
I agree, but a company with VAG's background shouldn't have released vehicles like the Golf MK8 and even worse initially the ID.3 with badly flawed software / hardware on the unsuspecting public, dealers and importers - with a promise of an imminent software update to fix things.
Importers and dealers were then left to try and placate a lot of justifiably frustrated buyers for considerable long periods of time waiting for said quick fix software update. The quick fix in my case was sixteen months after taking possession of the vehicle.
Only after the final fix have I for one been able to enjoy the car, free of almost daily system errors, frustration and disappointment. Rant over!
 
Last edited:

Carlosfandang0

Drag Racing Champion
I am very confused too, the only way my Nav database could have updated is via those software updates that VW released over the past few weeks. Haven't been with the dealer since the 1896 / IS software update in May last. I have never downloaded anything from or even visited that VW website and the only USB drive I have in the car is one containing MP3 files!
By the way had another of those software updates this evening, at least the fifth in as many weeks or less, all showing the same details..........
View attachment 257288
I had a map update OTA a few weeks ago (UK) I don’t have any data subscriptions or such like, the only way it can have connected to VW servers is via the in built SIM card.
 

Massimo 2323

Go Kart Champion
Until you have the weconnect plus the navigation database will get downloaded OTA. While the other system updates will always come OTA as only the Weconnect (Not Plus) is necessary.
To check the weconnect subscription go in Shop / WeConnect and you should see the subscription period.
Maps.png
 

LMWT

Go Kart Newbie
It turns out that, without my knowledge, I do have an active WeConnect+ subscription, 🤷‍♂️View attachment 257454
I did a bit of digging in the app and I also have an active WeC+ subscription :eek:, apparently purchased in April 2021. As I have no knowledge or financial record of purchasing said subscription, have to assume that it may have been included in the original vehicle purchase price (January 2021) and was only activated presumably by me on the date shown on the attached snip from the app........................

Screenshot_20220806-213526.png:unsure::confused:
 

Massimo 2323

Go Kart Champion
With the Discovery Pro i got 3 year weconnect plus subscription.
Looking at the latest brochure in Ireland the Golf 8 comes with Discovery Media and 1 year weconnect plus subscription.
C16A6A6B-9853-4BB4-A149-B9691CF0FC80.jpeg
 

TwoSheds

New member
I was told by VW Digital ( Germany ), when I had another query about We Connect , that the Nav Map updates are done automatically OTA without any notification to customers.

They now do up to 12 map updates per year OTA for We Connect Plus subscribers
 

mageor

New member
As if I haven t had enough problems with my golf... I recently acquired a new one... Vw never stops to surprise me.... The problem now is that I cannot change my privacy settings and I cannot perform factory settings reset by via the menu option.... Is there any other hard reset option by some key combination or something like that... When I am trying to factory reset it gives me a message of privacy setting not appropriate. I also cannot add basic user...
 

daveb15

Passed Driver's Ed
I noticed tonight that VW have added the ability to read text messages on Apple iPhone via the Bluetooth interface, previously you could only do that on android phones or on Apple CarPlay.
 

OJT23

New member
I’m trying to get CarPlay working on my golf mk8. When I click app-connect it says please visit the shop but there is no app-connect on the shop. Does anyone have any ideas? The dealer is saying there is no update for my car yet. Thanks in advance
 

Attachments

  • A8064A30-2C8E-4726-99D3-6B2E153C6036.jpeg
    A8064A30-2C8E-4726-99D3-6B2E153C6036.jpeg
    1.5 MB · Views: 23
  • 92D777C2-6C4B-4C8C-9837-85BAC49A4390.jpeg
    92D777C2-6C4B-4C8C-9837-85BAC49A4390.jpeg
    4.3 MB · Views: 22

TheDutchieGolf8

New member
After numerous unsuccessful tries I decided it's pointless to wait and scheduled an appointment for next Wednesday with the service.

Did you also try removing the We Connect user and factory reset the car? After I did this the SHOP tile is no longer present on the homescreen. It was there before.
Regarding the homescreen the manual says: "Touch the tile and keep your finger on the screen until an additional window opens." No matter how long I keep my finger on a tile there is NO additional window. I can only move the tile around.
I also have to enter my S-PIN when I start the car in the morning eventough I clicked on "don't ask again". If the car is parked for a short time only, then it doesn't ask for the S-PIN. :)

I also had problems with Apple Music streaming via my iPhone. It simply stopped playing music after a few seconds and started buffering for 20-30 seconds. At first I found out that if I disable the E-SIM then Apple Music streaming works and the car is still online, reporting data to We Connect.
Then I guess on the Apple support forum an Audi user had the same problem and found that disabling the hotspot in the infotainment for his phone made Apple Music to stream again with enabled E-SIM. Works for me too.

VW software is utter garbage and it negatively impacts user experience. They shouldn't have launched the car in this half baked state.
Had the same issue as you with Apple Music. Disabling the e-Sim made it work. All other functions were also good with doing that, only thing is the blue dot with a 1 in it, thinking you might have an update waiting.. but, disabling the hotspot didn’t work for me, because it would disconnect the complete iPhone from the infotainment system. Making it impossible to use.

After the update last week to 1896, e-Sim didn’t have to be disabled anymore to make Apple Music stream. Until today, where it had a tiny hickup while streaming. Hoping it was just a onetimer.

Another issue I had after the update to 1896, is a strange behaviour of the gearbox (so it seems). I wonder if any of you guys have the same problem. When braking slowly (e.g. from 50 kmh to 0 kmh) it seems that from 3rd gear to 2nd gear, the gearbox or clutch seems to disengage pretty abruptly. So that feels as if the brakes don’t work for half a second. It makes you feel like you move forward pretty quick and very shortly. It feels very unpleasant and I hope they can fix it. Car is 2 years old, and although downshifting wasn’t as smooth as my previous Golf 7 DSG, its now worse than it was before the 1896 update.

I’m at:

PART: 5H0035816G
HARDWARE: H56
SOFTWARE: 1896
ABT HARDWARE: H40
ABT SOFTWARE: 3074
 
Had the same issue as you with Apple Music. Disabling the e-Sim made it work. All other functions were also good with doing that, only thing is the blue dot with a 1 in it, thinking you might have an update waiting.. but, disabling the hotspot didn’t work for me, because it would disconnect the complete iPhone from the infotainment system. Making it impossible to use.

After the update last week to 1896, e-Sim didn’t have to be disabled anymore to make Apple Music stream. Until today, where it had a tiny hickup while streaming. Hoping it was just a onetimer.

Another issue I had after the update to 1896, is a strange behaviour of the gearbox (so it seems). I wonder if any of you guys have the same problem. When braking slowly (e.g. from 50 kmh to 0 kmh) it seems that from 3rd gear to 2nd gear, the gearbox or clutch seems to disengage pretty abruptly. So that feels as if the brakes don’t work for half a second. It makes you feel like you move forward pretty quick and very shortly. It feels very unpleasant and I hope they can fix it. Car is 2 years old, and although downshifting wasn’t as smooth as my previous Golf 7 DSG, its now worse than it was before the 1896 update.

I’m at:

PART: 5H0035816G
HARDWARE: H56
SOFTWARE: 1896
ABT HARDWARE: H40
ABT SOFTWARE: 3074
Do not completely disable hotspot and leave e-Sim enabled. Go to Settings -> Wi-Fi -> Infotainment system as hotspot -> Connected devices
Here you should see your connected iPhone. Click on the globe next to it to have it crossed, then Apple Music streaming works. (see attachment)

Anyhow I had 1896 reinstalled at the service last week. I had my primary user back and all was good for a couple of days until today with a permanent SOS fault. Call button's indicator is red. Nevertheless I pressed it and it was working, it put the call through. The SOS warning with exclamation did not went away though but the indicator led went green. Madness!

I'm getting sick and tired of all this mess and I'm seriously considering Consumer Protection at this point.
 

Attachments

  • ACEFA3C3-F07B-45B0-B46F-0726E4E5755B.jpeg
    ACEFA3C3-F07B-45B0-B46F-0726E4E5755B.jpeg
    1.5 MB · Views: 24
Last edited:

Maturedriver

Go Kart Newbie
Do not completely disable hotspot and leave e-Sim enabled. Go to Settings -> Wi-Fi -> Infotainment system as hotspot -> Connected devices
Here you should see your connected iPhone. Click on the globe next to it to have it crossed, then Apple Music streaming works. (see attachment)

Anyhow I had 1896 reinstalled at the service last week. I had my primary user back and all was good for a couple of days until today with a permanent SOS fault. Call button's indicator is red. Nevertheless I pressed it and it was working, it put the call through. The SOS warning with exclamation did not went away though but the indicator led went green. Madness!

I'm getting sick and tired of all this mess and I'm seriously considering Consumer Protection at this point.

I suspect you will have to have the SOS module replaced.

I do wonder how much all the many issues with the Mk8 Golf is costing VW 🤔.
 
  • Haha
Reactions: tos
Top