GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

Software Update

rob1984

New member
Hello guys,

Glad I am not the only one experiencing these issues.

I have had the car for ten weeks from brand new and am disappointed to say the least. I have come to the conclusion that the car thinks it’s on the European continent and should be a left hand drive and driven on the left. More details below.

The car has been in to the local dealership for two days only to be told that there are over 150 faults but no software updates to address any of them. I was only aware of a few.

I bought the car from a dealership 80 miles as they were they offered the best price through CarWow.

Having read the above comments in full I will have a look at my software version tomorrow.

Here is the e Mail I sent to the dealership I purchased it from. They are coming to take it away for three days next week but seem to be unaware of any of these issues. They are not closed to the idea of buying the car back from me and cancelling the agreement or replacing the car with a new factory order but would like the opportunity to inspect it themselves which is fair enough.

The faults I am experiencing with the car are as follows:

Adaptive Cruise Control and Dynamic Road Sign Recognition errors

When using the adaptive cruise control it randomly changes the selected speed. Sometimes this is when it genuinely detects a road signs, sometimes there is no road sign leading me to think it is taking the data from the GPS. Either way, it sets the speed in KPH, not MPH. This is extremely dangerous as when I am driving on the motorway at 70MPH and approaching an area of roadworks it will detect the 50MPH sign, display 50 on the dashboard but set the speed to 29MPH with is 50KPH. I can not find an option to disable to Dynamic Road Sign function.

Other triggers include:

- detecting the speed limit signs on the back of foreign lorries which creates a dangerous situation when I am overtaking on the motorway (example photo below)
- detecting speed limit signs that are not on the road I am travelling on such as slip roads/motorway exits and at road junctions.

Please see this forum for further details:

https://www.vwroc.com/forums/topic/39510-mk8-adaptive-cruise-control-faulty/

Lane Assist/Side Assist (?)

I am not sure which feature is causing this issue but when driving in the middle lane on the motorway and I approach a vehicle travelling slower in the first/left lane the car breaks slightly. I assume it thinks I am undertaking as the vehicle is set up to think I should be driving on the right hand side of the road and I cant seem to change it despite there being an option to select left hand side in the lights menu. If I select left hand side it just changes back to right hand side, again, possible taking data from the GPS? The manual states that a permanent change can be done by a dealership. When the car is slowing down it will display a car in the left lane on the dashboard. The only way to stop my car from slowing down is to tap the accelerator pedal, then the car disappears from the dashboard and the selected speed is resumed. I think the car thinks I am undertaking as any vehicle at any speed on my right do not cause this issue.

Music from my phone skips and jumps every few seconds. This occurs:

- when streaming music through the mobile network on Spotify
- when playing music stored locally on my phone
- both wirelessly and through the USB cable
- iPhone 12 Max Pro has been formatted to factory setting and reinstalled and the problem persists
- I read online that smart watches and similar devices can cause interference but the problem remains when there are no other devices in the car and the hardwired dashcam is unplugged.

Notification "SOS function has failed - contact workshop"

- this problem is intermittent

Wi-fi connection needs to be re-established every time the engine is started

- after every engine start there is a notification "media streaming unavailable - please establish a wifi connection first". This is not a major problem but seems odd to have to reconnect every time when the car has Amazon Alexa and many other web based features built in which would be handy to use.

The car has been at VW in Swindon to have these issues looked at for the past two days. They were unable to fix any of the problems I have reported but found a total of over 150 errors when the plugged the car in, most of whch were unknown and not apparent to me. They didn't explain them all to me and were not keen to give me a copy of the paperwork. They acknowledged that the cruise control error was a known issue and provided me with a questionnaire from VW to detail further occurrences. They also advised that there is no software update to solve it at the moment.

I get the impression the car thinks it is in another country, presumable Germany, where the speed limits are in KPH, where I should be driving on the right hand side of the road and overtaking should be done on the left hand side hence all of these issues.

What is more confusing is that none of these issues were present when I first took delivery of the car eight weeks ago on 11th May. They have all started in the last six weeks or so. I work at Heathrow Airport so 99% of my driving is on the M4 and 99% of the time the cruise control is engaged so I would have noticed it from the start. I wonder if the car updates some things through the cars internal SIM card?
 

Maturedriver

Ready to race!
At least your dealer is aware of the Mk8 Golf‘s software issues. With my dealer, either I’m only customer who has issues or they know there are problems but pretend they don’t exist. We shouldn’t have to put up with this sh*t.
 

tos

Passed Driver's Ed
- after every engine start there is a notification "media streaming unavailable - please establish a wifi connection first"
Mine did that too, after I tried once phone wifi (and tidal app in infotainment). I ordered 1gb "free data plan" from shop and notification is not there anymore.

When the free data is used out....?
There is app for phone which turns phone wifi on, when it connects cars bluetooth. I had this with my previos tiguan.
 

koolmacher

New member
My Golf had a long list of fault codes when in for travel assist faults the technician said they were mainly down to low charge in the 12v battery as the car had been standing in the compound at the garage I bought it from for a while, they couldn't clear travel assist faults though and that needed a new control module which one I don't know as that's all it was described as they had my car 4 weeks to do this!
 

nicba1010

New member
Hi, I own a Mk8 in Croatia and I've been having a ton of small issues that are fckng pissing me off.

Travel assist randomly disabled and then came back on. Parking sensors disabled yesterday for an hour. When opening door the speakers make a "prrrrr" sound. Also happens when I press the unlock button and the car door is open.

I love the car but this shit is driving me nuts. Do i need have recordings of all this before taking it to the dealer or can they read the codes and see logs that this happens?
 

Attachments

  • IMG_20210721_092857.jpg
    IMG_20210721_092857.jpg
    1.7 MB · Views: 119

Massimo 2323

Go Kart Newbie
Any problems i had i’ve made video recordings because some issues dont give fault codes and also they input these videos on the VW server… so i was told…
 

airforced

New member
Hi nicba - It is best to make a list of the problems to hand to the garage when it goes in for two reasons.
1. You have a record for future reference, should you need it, of what you have reported
2. The garage may hand that record to the Tec who is looking at your car. A job sheet may not give sufficient detail (as far as you are concerned) to the person trying to sort out the problems

And as Massimo has said not all the faults may not produce a fault code so your notes may prove valuable.
 

nicba1010

New member
Thanks guys, i have recordings or pics of most like this. Honestly i won't ever buy a car from VW again if this is the kind of bull i can expect.
 

Attachments

  • IMG_20210720_225128.jpg
    IMG_20210720_225128.jpg
    1.1 MB · Views: 179
  • IMG_20210525_132446.jpg
    IMG_20210525_132446.jpg
    1.4 MB · Views: 176
Hi All!

My Golf Mk8 Style 1.5 eTSI DSG was purchased last September and it's on version 1664 currently. My main software problem is that the car frequently (once a week at least) switches to Guest user. When this happens the small Globe icon at the top left corner is greyed out and I can't access car data in the We Connect app on my iPhone neither on the webstite. I cannot decide whether it's a connection issue with the car itself or VW We Connect services are down. Nevertheless it usually works ok the following day.

Another issue was streaming music with my iPhone 12 Pro using the phone's cellular data. Music stopped every few seconds. If the music was downloaded to the phone beforehand then streaming was flawless. I found out that by disabling eSim in the car streaming over cellular is working fine. Also the We Connect app on the phone correctly shows driving data even with eSim disabled and the globe is white at the top left (when it's not in Guest mode) 😊

Called my dealer and based on my VIN number they say there are software updates avaiable and I should take the car to them to apply these updates. Maybe it will cause more harm than good. I don't really trust VW software anymore. 🙂
 

Handydave

Passed Driver's Ed
Could it be that you are using two different keys,, with one linked to your profile and the other not, meaning that, when you use it, the car is in guest user mode?

In guest user mode, privacy defaults to most restrictive, and the car will not connect to VW servers.

Our car was on 1664 and was updated to 1668 in January 2021. That version has been very stable.
 
Could it be that you are using two different keys,, with one linked to your profile and the other not, meaning that, when you use it, the car is in guest user mode?

In guest user mode, privacy defaults to most restrictive, and the car will not connect to VW servers.

Our car was on 1664 and was updated to 1668 in January 2021. That version has been very stable.
I'm using only one key with one user profile who is the master user. It happens only when the globe is greyed out which indicates connectivity issues.
 

Nickand

New member
Lane Assist/Side Assist (?)

I am not sure which feature is causing this issue but when driving in the middle lane on the motorway and I approach a vehicle travelling slower in the first/left lane the car breaks slightly. I assume it thinks I am undertaking as the vehicle is set up to think I should be driving on the right hand side of the road and I cant seem to change it despite there being an option to select left hand side in the lights menu. If I select left hand side it just changes back to right hand side, again, possible taking data from the GPS? The manual states that a permanent change can be done by a dealership. When the car is slowing down it will display a car in the left lane on the dashboard. The only way to stop my car from slowing down is to tap the accelerator pedal, then the car disappears from the dashboard and the selected speed is resumed. I think the car thinks I am undertaking as any vehicle at any speed on my right do not cause this issue.

Music from my phone skips and jumps every few seconds. This occurs:

- when streaming music through the mobile network on Spotify
- when playing music stored locally on my phone
- both wirelessly and through the USB cable
- iPhone 12 Max Pro has been formatted to factory setting and reinstalled and the problem persists
- I read online that smart watches and similar devices can cause interference but the problem remains when there are no other devices in the car and the hardwired dashcam is unplugged.
For Lane Assist try turning "Eco Assist" off. That did the trick for me and the car does not slow down after detecting a car on the left side anymore.

As for music, I've been having the same problems with Apple Music too. Make sure that you have Mobile Data on for music streaming and that will solve a lot of your problems but they will keep on happening. I don't know if it's something that has to do with Apple and Carplay or VW's software. Hopefully in the future this will be sorted !

Hope that I've helped !
 

Maturedriver

Ready to race!
Had my software updated to 1668 on the 8th July which I hoped would sort out my car confusing kph with mph. Yesterday (9th August) it started doing it again. With the cruise control set at 30 mph, suddenly the car showed 19 mph (which is actually 30 kph) on the cruise control speed display and then immediately started slowing down to 19 mph. As it got to that new lower speed it then accelerated back up to 30 mph and then back down to 19 mph again. It did this repetitively! Probably to the annoyance of the following lorry. According to the YouTube video by volkswizard entitled ‘Dangerous faults that Volkswagen can’t fix - Mk8 GTi Clubsport update’ there is no current cure for those who have software 1664/1668.
 
Last edited:

goofee

New member
Hi, any car dealer that sells the VW Golf MK8 will have a massive problem because VW customer service will say too the owner that the faulty car's with no update available are the car dealers problem and not VW problem these cars are not fit for the purpose and should not be sold and handed back to VW.
 
Top