GOLFMK8
GOLFMK7
GOLFMK6
GOLFMKV

We Connect issue

Maturedriver

Passed Driver's Ed
My We Connect was working fine. I could look up car data on my iPhone. Then a message appeared on the centre screen which didn’t stay there long enough for me to read. Now the We Connect app says ‘This online service is deactivated in your vehicle. Please activate this service in your infotainment system setting’. How does one do that? Do I have to set up We Connect again.

I love and hate modern technology in equal measure. The ‘Mature’ element of my name doesn’t help!
 

Handydave

New member
I think VW’s servers have been playing up over the last few days. Some Mk8 owners (like me) have reported the car losing connectivity (globe on top right of infotainment screen greyed out) and then reconnecting after a day or so. Others have additionally reported being logged out as Primary User.

I suggest:

- Switch on ignition and see if you are logged in as the Primary User or a Guest User - it will probably indicate this on the startup screen, but if not go to Home / Users to check.

- If you’re logged in as a Guest User, then the car will probably not be connected to VW servers (globe greyed out). This is because, in Guest User mode, privacy settings default to most restrictive each time the vehicle is started, which prevents connection.

- To fix this you’ll need to set Privacy to least restrictive (share my position) and that should force the car to connect after 30 seconds or so (globe showing white). You can set Privacy in the Users menu.

- Once the vehicle is connected, you can try to log in as the Primary User. Hopefully, that option will be available to you in the User Menu. But if not, you may need to add yourself again as the Primary User (you’ll need both sets of keys to do this).

Hope this helps a bit, and good luck....
 
Last edited:

Maturedriver

Passed Driver's Ed
Thanks Hanydave. Like I said, it showed on my iPhone - ‘This online service is deactivated in your vehicle. Please activate this service in your infotainment system setting’. On the car I checked everything including Privacy settings and that the Primary User was me. Through desperation I got the car out of the garage and hey presto it worked. Never had to do that before. Why didn’t the bloody phone show something like ‘Your car has lost connection due to crap signal’. Being a cynic I suspect something else will trigger a fault with We Connect in a few days/weeks/months.
 

Massimo 2323

Ready to race!
That has happened in Italy also where many Golf 8 weconnect users had the same error. I also had the same problem, surely due to VW servers acting up.
Once I logged back in with my primary user and set privacy to share my position it worked again.
 
Top